Rock5's Mail Mods

Additional botting resources. Addons may be either for the game itself or for the RoM bot.
Forum rules
Only post additional bot resources here. Please do not ask unrelated questions.
Message
Author
User avatar
nerf
Posts: 85
Joined: Thu Jan 27, 2011 10:44 am

Re: Rock5's Mail Mods

#761 Post by nerf » Wed Feb 28, 2018 5:29 am

I copied and pasted this,

Code: Select all

UMM_SendByNameOrId("CharacterName",{"123456"})
and it works, but it sends all the elements to the recipient, what I want is to send a stack of 50, I know it is possible, but I do not know how to add what is missing.

Rickster
Posts: 291
Joined: Sun Oct 24, 2010 4:23 pm

Re: Rock5's Mail Mods

#762 Post by Rickster » Wed Feb 28, 2018 4:54 pm

Try this:

UMM_SendAdvanced(_recipient, _itemTable, _quality, _reqlevel, _worth, _objtype, _statNo, _dura, _amount, _stacksize, _fusedtier)

Code: Select all

UMM_SendAdvanced("CharacterName",{"123456"}, nil, nil, nil, nil, nil, nil, nil, 50, nil)

User avatar
nerf
Posts: 85
Joined: Thu Jan 27, 2011 10:44 am

Re: Rock5's Mail Mods

#763 Post by nerf » Thu Mar 01, 2018 9:38 am

thanks Rickster!

lolilol666
Posts: 11
Joined: Sun May 03, 2020 5:10 pm

Re: Rock5's Mail Mods

#764 Post by lolilol666 » Thu Nov 05, 2020 2:20 pm

Hello,

I try to use Mail mod,

But i Have this error :
2020-11-05 20:15:19 - ...cripts/rom/userfunctions/addon_Rock5s_Mail_Functions.lua:57: attempt to concatenate local 'slotid' (a nil value)

When I use this

Code: Select all

UMM_SendByRange("Charaname", 61, 240)
Do you know why?

Best regards

User avatar
Administrator
Site Admin
Posts: 5243
Joined: Sat Jan 05, 2008 4:21 pm

Re: Rock5's Mail Mods

#765 Post by Administrator » Thu Nov 05, 2020 4:49 pm

Just took a look and it seems like it was because there was a misalignment with the slot numbers and so it intended to mark an item from your bag (slot 61, for example) but was instead attempting to mark an item from itemshop bag (slot 1) which may or may not exist; if it didn't, you'd get that error.

Easy fix. However, keep in mind that as of a few months ago, they changed how the inventory slot numbers work. As you're using it, it isn't very problematic though. But if you had configured a range of say, 61-66, you might expect that to correspond to the top row of your first bag, when it actually will be seemingly random items in the first bag (RoM jumbles the indexes around every time you "organize" a bag).

Anyways, go ahead and update your RoM bot files then re-copy the mailmod folder over to the RoM interface addons folder, restart the game, and it should be working again.

mattstar81
Posts: 42
Joined: Tue Feb 02, 2016 5:14 pm

Re: Rock5's Mail Mods

#766 Post by mattstar81 » Sat May 14, 2022 1:20 pm

Hello,
i have this Problem

2022-05-14 20:18:50 - ...xxx/addon_Rock5s_Mail_Functions.lua:118: bad argument #1 to 'tonumber' (value expected)

this is my wp

UMM_SendByRange("xxx",61, 120)

could someone help me

User avatar
Administrator
Site Admin
Posts: 5243
Joined: Sat Jan 05, 2008 4:21 pm

Re: Rock5's Mail Mods

#767 Post by Administrator » Sat May 21, 2022 9:23 am

I'm not able to reproduce this issue.

Please ensure that you have the RoM bot scripts fully updated; either download the latest source and overwrite ALL local files (will not modify your profiles or anything), or use the rombot_updater tool included in the rom-bot folder (if you don't see it, you're out of date).

If that doesn't work, please try re-copying all of the contents (the 4 folders) of the
devtools
folder into your Runes of Magic
Interface/Addons/
directory.

Post Reply

Who is online

Users browsing this forum: Bing [Bot] and 0 guests