Search found 4476 matches

by Administrator
Mon Jul 01, 2024 7:42 am
Forum: Runes of Magic
Topic: Fix for Wander Waypoints by Rock
Replies: 1
Views: 583

Re: Fix for Wander Waypoints by Rock

Can you please link to the script you're talking about?
Also, please explain *what* isn't working about it. If I can't reproduce the exact issues you're seeing, it likely won't be fixed.
by Administrator
Mon Apr 15, 2024 8:16 am
Forum: Userfunctions, waypoint scripts, etc.
Topic: Item cooldown
Replies: 2
Views: 8991

Re: Item cooldown

The game had an update awhile ago that moved where an item's cooldown is stored. That made it really difficult to keep track of. It looks like I put that temporary fix in to just make it work while I had patched up all the other changes and then just forgot about the item cooldown. I just pushed up ...
by Administrator
Thu Mar 21, 2024 3:19 pm
Forum: Userfunctions, waypoint scripts, etc.
Topic: teleport follow userfunction
Replies: 3
Views: 8364

Re: teleport follow userfunction

I just tested this out myself. As far as I can tell, it works just fine. To test, I first got the address of monster. Then, I just plugged it into the function like so: local followtgt = 0x4B747800; telefollow(10, followtgt); When ran, my character continually teleported a few steps forward until re...
by Administrator
Mon Jan 29, 2024 12:22 pm
Forum: Runes of Magic
Topic: Bot not prperly fighting - problem with bot or my installation?
Replies: 19
Views: 15883

Re: Bot not prperly fighting - problem with bot or my installation?

Following up on this again -- the issue OluxZarjaNebesnogo was having has been resolved and the fix is in the most recent script update.
by Administrator
Sun Jan 28, 2024 2:26 pm
Forum: Runes of Magic
Topic: Bot not prperly fighting - problem with bot or my installation?
Replies: 19
Views: 15883

Re: Bot not prperly fighting - problem with bot or my installation?

I'm not able to reproduce the Warden Briar Shield issue; mind if I borrow your character again? Since I assume you changed your password (and you should have!), I'll need you to change it again and send me the new password. The "Exit early" thing is an easy fix and I'll take care of that w...
by Administrator
Sat Jan 27, 2024 9:00 am
Forum: Runes of Magic
Topic: Bot not prperly fighting - problem with bot or my installation?
Replies: 19
Views: 15883

Re: Bot not prperly fighting - problem with bot or my installation?

The "Exit early" thing was a debug statement I accidentally left in. It's harmless and you can ignore that. For the other issues, I'll need to find some time to investigate those. Been pretty busy lately, so can't commit to anything at the moment. Can you confirm if you're playing on the G...
by Administrator
Tue Jan 23, 2024 4:00 pm
Forum: Runes of Magic
Topic: Bot not prperly fighting - problem with bot or my installation?
Replies: 19
Views: 15883

Re: Bot not prperly fighting - problem with bot or my installation?

Following up on this, OluxZarjaNebesnogo and I had worked out a solution in PM. The fix has been released; use the updater to get the fix.
by Administrator
Mon Jan 22, 2024 2:09 pm
Forum: Runes of Magic
Topic: Bot not prperly fighting - problem with bot or my installation?
Replies: 19
Views: 15883

Re: Bot not prperly fighting - problem with bot or my installation?

About skill IDs. Example for the warlock/priest class: "PRIEST_RISING_TIDE" has an elite skill that removes casting time and now this skill has new IDs in the warlock/priest class combination. The bot continues to use the skill, but the console displays: Use MACRO: PRIEST_RISING_TIDE => *...
by Administrator
Mon Jan 22, 2024 8:09 am
Forum: Runes of Magic
Topic: Bad egg slot
Replies: 3
Views: 5742

Re: Bad egg slot

Thank you. Just pushed up another fix for that. I only have 2 pets to test with, but it should be fine.
by Administrator
Sun Jan 21, 2024 12:27 pm
Forum: Runes of Magic
Topic: Bad egg slot
Replies: 3
Views: 5742

Re: Bad egg slot

Found the problem. The address was out of date, and nothing useful in the autoupdater for it.
Go ahead and update your scripts and eggpets should begin working for you.
by Administrator
Sun Jan 21, 2024 11:40 am
Forum: Runes of Magic
Topic: Bot not prperly fighting - problem with bot or my installation?
Replies: 19
Views: 15883

Re: Bot not prperly fighting - problem with bot or my installation?

As it turns out, we might not necessarily need to do anything fancy with the IDs; the bot generally doesn't care about them too much. I've done some debugging and changed the skill ID for Rogue Shadowstab to one of the other variants, and the bot continued to use Shadowstab for me. It checks if you ...
by Administrator
Sat Jan 20, 2024 10:41 am
Forum: Runes of Magic
Topic: Bot not prperly fighting - problem with bot or my installation?
Replies: 19
Views: 15883

Re: Bot not prperly fighting - problem with bot or my installation?

So it would seem that each subclass has a variant for some skills. That's a pain in the butt. There's two ways I can see to get around this. First, is an easy solution: add a new skill line for each variant. Like so: <skill name="ROGUE_SCOUT_SHADOWSTAB" id="492329" range="50...
by Administrator
Fri Jan 05, 2024 9:55 am
Forum: Runes of Magic
Topic: name table .xml help
Replies: 1
Views: 4978

Re: name table .xml help

You would need to refactor the waypoint 16 code. We can actually simplify it a bit as a result. Simply iterate over the full list in nameTable and send the stones. This is untested, but it should look something like this: for counter = 1, #nameTable do repeat player:target_NPC(110793) -- Mailbox yre...
by Administrator
Tue Jan 02, 2024 2:24 pm
Forum: Runes of Magic
Topic: add more " clicks " when attack
Replies: 4
Views: 6153

Re: add more " clicks " when attack

So what's likely going on is that it thinks the skill cast is failing due to how the bot is waiting and checking on various things. Try this: <skill name="DIYCE_SKILL" range="180" type="damage" casttime="0" cooldown="1" target="enemy" prior...
by Administrator
Sun Dec 24, 2023 2:06 am
Forum: Runes of Magic
Topic: add more " clicks " when attack
Replies: 4
Views: 6153

Re: add more " clicks " when attack

But with running it like this MM only press the skill button x3 times and pause and press x3 again
Is that 3 times really quick, pause for a second, and then again, or is the delay longer?

This might sound counter-intuitive, but what if you set the cooldown to 1 instead of 0, does that help?
by Administrator
Wed Dec 20, 2023 4:02 pm
Forum: Runes of Magic
Topic: HEAL_FIGHT crash client
Replies: 6
Views: 7549

Re: HEAL_FIGHT crash client

For the Thunder skill, is it a ground-targeted AoE by chance?
by Administrator
Wed Dec 20, 2023 9:02 am
Forum: Runes of Magic
Topic: HEAL_FIGHT crash client
Replies: 6
Views: 7549

Re: HEAL_FIGHT crash client

Code is in
classes/party.lua
, around line 42:
function Party()
.
function healfight()
is around line 425.


I just noticed something: You'll need to have
ICON_FIGHT
set to
true
in your options. Then, the heal bot should also try to fight whichever targets you have set an icon for.
by Administrator
Tue Dec 19, 2023 12:29 pm
Forum: Runes of Magic
Topic: HEAL_FIGHT crash client
Replies: 6
Views: 7549

Re: HEAL_FIGHT crash client

Taking a look at the party healing function, it looks like it was pretty much hard-coded to do only one or the other, but not both.
The only way to get it to work would require a pretty big refactoring.
by Administrator
Mon Dec 11, 2023 6:50 pm
Forum: Runes of Magic
Topic: Free camera?
Replies: 2
Views: 5874

Re: Free camera?

I think part of how the bot works is by manipulating the camera, so unfortunately it's going to jerk around on you a bit. Not much that can be done about it, sorry.
by Administrator
Wed Nov 15, 2023 3:52 pm
Forum: Runes of Magic
Topic: Problem With Running the script
Replies: 1
Views: 5180

Re: Problem With Running the script

The first attempt was (mostly) right. At the script prompt, you should be running rom-bot/bot profile:l1-10 , assuming that rom-bot is the name of the folder inside micromacro/scripts . It looks like you named yours rom instead, which should be totally fine. Based on the error you're getting, I'm as...