Version 7.4.0.2897 progress

Runes of Magic/Radiant Arcana (http://www.runesofmagic.com)
Message
Author
User avatar
Administrator
Site Admin
Posts: 5020
Joined: Sat Jan 05, 2008 4:21 pm

Re: Version 7.4.0.2897 progress

#641 Post by Administrator » Sun Jul 05, 2020 9:09 am

Please open up log.txt and copy the last few lines out of that file with details about the error.

nuk79
Posts: 369
Joined: Mon May 17, 2010 3:40 pm

Re: Version 7.4.0.2897 progress

#642 Post by nuk79 » Sun Jul 05, 2020 5:05 pm

return "drinknew.xml", 1, 3
return "drinknew.xml", 1, 3

2 same strings in the different files called with 2 my characters in the log.xml

User avatar
Administrator
Site Admin
Posts: 5020
Joined: Sat Jan 05, 2008 4:21 pm

Re: Version 7.4.0.2897 progress

#643 Post by Administrator » Sun Jul 05, 2020 5:51 pm

nuk79 wrote:
Sun Jul 05, 2020 5:05 pm
return "drinknew.xml", 1, 3
return "drinknew.xml", 1, 3

2 same strings in the different files called with 2 my characters in the log.xml
Not log.xml, log.txt. It should be in the folder with MicroMacro. After the error occurs, you should see something like this in the last few lines:

Code: Select all

In main thread:
stack traceback:
	D:\sync\micromacro_v1_old\lib\lib.lua:570: in function <D:\sync\micromacro_v1_old\lib\lib.lua:568>

----------TRACEBACK END----------

nuk79
Posts: 369
Joined: Mon May 17, 2010 3:40 pm

Re: Version 7.4.0.2897 progress

#644 Post by nuk79 » Sun Jul 05, 2020 6:32 pm

In main thread:
stack traceback:
C:/Program Files/micromacro/scripts/rom/functions.lua:976: in function 'RoMScript'
C:/Program Files/micromacro/scripts/rom/settings.lua:1055: in function 'loadProfile'
scripts\rom/bot.lua:287: in function 'foo'
C:\Program Files\micromacro\lib\lib.lua:570: in function <C:\Program Files\micromacro\lib\lib.lua:568>

----------TRACEBACK END----------

2020-07-06 05:11:21 : IGF:\d303Fix.NumVer\:IGF [string "local a={d303Fix.NumVer} return a"]:1: attempt to index global 'd303Fix' (a nil value)
2020-07-06 05:11:21 : Execution error: Runtime error
2020-07-06 05:11:21 : Loaded plugin 'lxp'
2020-07-06 05:11:26 : Executing script 'bot.lua'


2020-07-05 23:34:28 : Bot userfunction 'Rock5s_Mail_Functions' successfully loaded.
2020-07-05 23:34:28 : Bot userfunction '30daymounts' successfully loaded.
2020-07-05 23:34:28 : Bot userfunction 'countmobs' successfully loaded.
2020-07-05 23:34:28 : Bot userfunction 'Fusion_Functions' successfully loaded.
2020-07-05 23:34:28 : Bot userfunction 'LoginNextChar' successfully loaded.
2020-07-05 23:34:28 : Bot userfunction 'speedhack' successfully loaded.
2020-07-05 23:34:28 : Bot userfunction 'swimhack' successfully loaded.
2020-07-05 23:34:28 : Bot userfunction 'teleport' successfully loaded.
2020-07-05 23:34:28 : Language: english
2020-07-05 23:34:43 : QUICK_TURN = true
2020-07-05 23:34:43 : Keyboard settings are from bindings.txt:
2020-07-05 23:34:43 : MOVE_BACKWARD S
2020-07-05 23:34:43 : MACRO 0
2020-07-05 23:34:43 : STRAFF_RIGHT D
2020-07-05 23:34:43 : ROTATE_LEFT Q
2020-07-05 23:34:43 : ESCAPE ESC
2020-07-05 23:34:43 : ROTATE_RIGHT E
2020-07-05 23:34:43 : JUMP BARRA SPAZIATRICE
2020-07-05 23:34:43 : MOVE_FORWARD W
2020-07-05 23:34:43 : TARGET_FRIEND CTRL (DESTRA)+TAB
2020-07-05 23:34:43 : STRAFF_LEFT A
2020-07-05 23:34:43 : TARGET TAB
2020-07-05 23:34:46 : findWindowList() returned 0 results. Window(s) not found or other error occurred.
2020-07-05 23:34:48 : findWindowList() returned 0 results. Window(s) not found or other error occurred.
2020-07-05 23:34:50 : findWindowList() returned 0 results. Window(s) not found or other error occurred.
2020-07-05 23:34:52 : findWindowList() returned 0 results. Window(s) not found or other error occurred.
2020-07-05 23:34:54 : findWindowList() returned 0 results. Window(s) not found or other error occurred.
2020-07-05 23:34:56 : findWindowList() returned 0 results. Window(s) not found or other error occurred.
Last edited by nuk79 on Mon Jul 06, 2020 6:46 am, edited 2 times in total.

nuk79
Posts: 369
Joined: Mon May 17, 2010 3:40 pm

Re: Version 7.4.0.2897 progress

#645 Post by nuk79 » Sun Jul 05, 2020 6:34 pm

2020-07-05 20:54:15 : Bot userfunction 'Rock5s_Mail_Functions' successfully loaded.
2020-07-05 20:54:15 : Bot userfunction '30daymounts' successfully loaded.
2020-07-05 20:54:15 : Bot userfunction 'countmobs' successfully loaded.
2020-07-05 20:54:15 : Bot userfunction 'Fusion_Functions' successfully loaded.
2020-07-05 20:54:15 : Bot userfunction 'LoginNextChar' successfully loaded.
2020-07-05 20:54:15 : Bot userfunction 'speedhack' successfully loaded.
2020-07-05 20:54:15 : Bot userfunction 'swimhack' successfully loaded.
2020-07-05 20:54:15 : Bot userfunction 'teleport' successfully loaded.
2020-07-05 20:54:15 : Language: english
2020-07-05 20:54:22 : Function 'bitAnd' is deprecated.

2020-07-05 20:54:22 : Function 'bitLShift' is deprecated.

2020-07-05 20:54:22 : Function 'bitRShift' is deprecated.

2020-07-05 20:54:24 : QUICK_TURN = true
2020-07-05 20:54:24 : Keyboard settings are from bindings.txt:
2020-07-05 20:54:24 : ESCAPE ESC
2020-07-05 20:54:24 : TARGET TAB
2020-07-05 20:54:24 : STRAFF_RIGHT D
2020-07-05 20:54:24 : JUMP BARRA SPAZIATRICE
2020-07-05 20:54:24 : ROTATE_RIGHT E
2020-07-05 20:54:24 : ROTATE_LEFT Q
2020-07-05 20:54:24 : MOVE_BACKWARD S
2020-07-05 20:54:24 : MACRO 0
2020-07-05 20:54:24 : TARGET_FRIEND CTRL (DESTRA)+TAB
2020-07-05 20:54:24 : MOVE_FORWARD W
2020-07-05 20:54:24 : STRAFF_LEFT A
2020-07-05 20:54:27 : Wrong value returned in update of item id: 202435
2020-07-05 20:54:27 : Wrong value returned in update of item id: 201014

nuk79
Posts: 369
Joined: Mon May 17, 2010 3:40 pm

Re: Version 7.4.0.2897 progress

#646 Post by nuk79 » Sun Jul 05, 2020 11:55 pm

how can i use home sweet home stone for swap class in kashaylan dailies??many years ago someone use it but i lost in site ......can you help me ?i add script for normal dailies:
Attachments
dailyeoj.xml
(815 Bytes) Downloaded 18 times

morc
Posts: 72
Joined: Thu Jan 02, 2020 7:32 am

Re: Version 7.4.0.2897 progress

#647 Post by morc » Mon Jul 06, 2020 2:27 am

Administrator wrote:
Sun Jul 05, 2020 9:09 am
Please open up log.txt and copy the last few lines out of that file with details about the error.
2020-07-06 09:13:31 : .../micromacro/scripts/rom/classes/memorytable.lua:91: attempt to index field '?' (a string value)
2020-07-06 09:13:31 : Execution error: Runtime error
2020-07-06 09:13:31 : Loaded plugin 'lxp'
2020-07-06 09:13:46 : Executing script 'bot.lua'
-------------------------------------------------------------------------------

2020-07-06 09:17:18 : Bot userfunction 'AOE' successfully loaded.
2020-07-06 09:17:18 : Bot userfunction 'housemaidPotions_V3' successfully loaded.
2020-07-06 09:17:18 : Bot userfunction 'mailfunctions' successfully loaded.
2020-07-06 09:17:18 : Bot userfunction 'mindenes' successfully loaded.
2020-07-06 09:17:18 : Bot userfunction 'Rock5s_Mail_Functions (1)' successfully loaded.
2020-07-06 09:17:18 : Bot userfunction 'Rock5s_Mail_Functions' successfully loaded.
2020-07-06 09:17:18 : Bot userfunction '30daymounts' successfully loaded.
2020-07-06 09:17:18 : Bot userfunction 'countmobs' successfully loaded.
2020-07-06 09:17:18 : Bot userfunction 'Fusion_Functions' successfully loaded.
2020-07-06 09:17:18 : Loading of audio file '.../micromacro/scripts/rom/userfunctions/alarm.wav' has failed
2020-07-06 09:17:18 : [WARN]: ...cro/scripts/rom/userfunctions/userfunction_gmmonitor.lua:33
Failed to load sound file 'alarm.wav'
2020-07-06 09:17:18 : Bot userfunction 'gmmonitor' successfully loaded.
2020-07-06 09:17:18 : Bot userfunction 'speedhack' successfully loaded.
2020-07-06 09:17:18 : Bot userfunction 'swimhack' successfully loaded.
2020-07-06 09:17:18 : Bot userfunction 'sync' successfully loaded.
2020-07-06 09:17:18 : Bot userfunction 'teleport' successfully loaded.
2020-07-06 09:17:18 : Language: english
2020-07-06 09:17:37 : QUICK_TURN = true
2020-07-06 09:17:37 : Keyboard settings are from settings.xml:
2020-07-06 09:17:37 : MOVE_BACKWARD S
2020-07-06 09:17:37 : MACRO F9
2020-07-06 09:17:37 : TARGET_FRIEND J
2020-07-06 09:17:37 : JUMP Space
2020-07-06 09:17:37 : MOVE_FORWARD W
2020-07-06 09:17:37 : STRAFF_LEFT A
2020-07-06 09:17:37 : ROTATE_RIGHT E
2020-07-06 09:17:37 : STRAFF_RIGHT D
2020-07-06 09:17:37 : TARGET Tab
2020-07-06 09:17:37 : ROTATE_LEFT Q
2020-07-06 09:17:41 : Wrong value returned in update of item id: 20745
2020-07-06 09:17:43 : findWindowList() returned 0 results. Window(s) not found or other error occurred.
In main thread:
stack traceback:
.../micromacro/scripts/rom/settings.lua:1352: in function 'updateSkillsAvailability'
scripts\rom/bot.lua:818: in function 'foo'
...\micromacro\lib\lib.lua:570: in function <...\micromacro\lib\lib.lua:568>

----------TRACEBACK END----------

morc
Posts: 72
Joined: Thu Jan 02, 2020 7:32 am

Re: Version 7.4.0.2897 progress

#648 Post by morc » Tue Jul 07, 2020 4:04 am

I do not understand :(

I tested it with an empty waypoint (contains only waypoints, attached), same error (m/r, m/-, w/-, r/-): not class dependent
I don't have any items starting with 20745

but for example "far_energetic" waypoint work perfectly with this character
Attachments
farsitan.xml
(649 Bytes) Downloaded 15 times

morc
Posts: 72
Joined: Thu Jan 02, 2020 7:32 am

Re: Version 7.4.0.2897 progress

#649 Post by morc » Tue Jul 07, 2020 7:44 am

so...

I swapped it back the inventoryitem.lua a modified version (attached)
it works with this

which does not work properly:
m/r buffs
waypoint coordinates (runs over, runs back, searches for space)
--port parameter (teleport) (maybe char speed?)
speedhack
Attachments
inventoryitem.lua
(3.29 KiB) Downloaded 24 times

tristanlol
Posts: 14
Joined: Sun Dec 29, 2019 5:59 pm

Re: Version 7.4.0.2897 progress

#650 Post by tristanlol » Wed Jul 08, 2020 10:41 am

Hi!

Are now custom waypoints working well? I've created a simple waypoint file (by using createpath script) to harvest, but I have several problems when using it.

The first one is the level check in CPlayer::harvest function, it seems that the player harvest level is not working as expected. It returns a XXe-41 number in my case, so the harvest is never done. I've bypassed that issue by removing the level check.

The second one is the path that is taking the character to go to each waypoint. It fails a lot, comes back, forward again, and almost never reachs the exact points. I have set the WAYPOINT_DEVIATION value to 2, so I think it's right.

Am I the only one having this issues?

Thanks!
Last edited by tristanlol on Wed Jul 08, 2020 3:57 pm, edited 1 time in total.

morc
Posts: 72
Joined: Thu Jan 02, 2020 7:32 am

Re: Version 7.4.0.2897 progress

#651 Post by morc » Wed Jul 08, 2020 1:51 pm

these are real problems :(

User avatar
Administrator
Site Admin
Posts: 5020
Joined: Sat Jan 05, 2008 4:21 pm

Re: Version 7.4.0.2897 progress

#652 Post by Administrator » Wed Jul 08, 2020 4:53 pm

I believe the memorytable error should now be fixed! Hopefully. Can someone confirm?

tristanlol wrote:
Wed Jul 08, 2020 10:41 am
Hi!

Are now custom waypoints working well? I've created a simple waypoint file (by using createpath script) to harvest, but I have several problems when using it.

The first one is the level check in CPlayer::harvest function, it seems that the player harvest level is not working as expected. It returns a XXe-41 number in my case, so the harvest is never done. I've bypassed that issue by removing the level check.
That should be fixed now and harvesting is working for me here.
The second one is the path that is taking the character to go to each waypoint. It fails a lot, comes back, forward again, and almost never reachs the exact points. I have set the WAYPOINT_DEVIATION value to 2, so I think it's right.
That one is a lot harder to figure out. Are you using the modified inventoryitem.lua file someone posted earlier? That may cause invalid item reads, which slows the bot down enough that it's not able to process the characters' position fast enough to notice you're in the right area.

With the fixes I just pushed up, I'm not able to reproduce the problem here. Please try updating first and see if that helps. If you still have problems, do you mind posting your computer specs?

morc
Posts: 72
Joined: Thu Jan 02, 2020 7:32 am

Re: Version 7.4.0.2897 progress

#653 Post by morc » Thu Jul 09, 2020 7:06 am

with the newest version (virgin install):

Add prediction for block 235000, branch 0xBC
Add prediction for block 520000, branch 0x258
Add prediction for block 521000, branch 0x25C
Add prediction for block 211000, branch 0x298
Add prediction for block 214000, branch 0x2A4

Wrong value returned in update of CItem id: 201086
Wrong value returned in update of CItem id: 202903
Wrong value returned in update of CItem id: 203784
Wrong value returned in update of CItem id: 208736
Wrong value returned in update of CItem id: 202435
Wrong value returned in update of CItem id: 202904
Wrong value returned in update of CItem id: 202905
Wrong value returned in update of CItem id: 201619
Wrong value returned in update of CItem id: 202322
Wrong value returned in update of CItem id: 201445
Wrong value returned in update of CItem id: 202540
Wrong value returned in update of CItem id: 201141
Wrong value returned in update of CItem id: 201139
Wrong value returned in update of CItem id: 202902
Wrong value returned in update of CItem id: 201967
Wrong value returned in update of CItem id: 201136
Wrong value returned in update of CItem id: 201014
Wrong value returned in update of CItem id: 203178
Wrong value returned in update of CItem id: 208531
Wrong value returned in update of CItem id: 200559
Wrong value returned in update of CItem id: 201618
Wrong value returned in update of CItem id: 203488
Wrong value returned in update of CItem id: 206946
Wrong value returned in update of CItem id: 224776
Wrong value returned in update of CItem id: 203495
Wrong value returned in update of CItem id: 520707
Wrong value returned in update of CItem id: 207969
Wrong value returned in update of CItem id: 202153
Wrong value returned in update of CItem id: 207970
Wrong value returned in update of CItem id: 207652
Wrong value returned in update of CItem id: 202916
Wrong value returned in update of CItem id: 207971
Wrong value returned in update of CItem id: 202301
Wrong value returned in update of CItem id: 200150
Wrong value returned in update of CItem id: 202879
Wrong value returned in update of CItem id: 202153
Wrong value returned in update of CItem id: 204222
Wrong value returned in update of CItem id: 203024
Wrong value returned in update of CItem id: 204925
Wrong value returned in update of CItem id: 207022
Wrong value returned in update of CItem id: 203024
Wrong value returned in update of CItem id: 200150
Wrong value returned in update of CItem id: 200427
Wrong value returned in update of CItem id: 204510
Wrong value returned in update of CItem id: 203496
Wrong value returned in update of CItem id: 207656
Wrong value returned in update of CItem id: 206874
Wrong value returned in update of CItem id: 208520
Wrong value returned in update of CItem id: 208520
Wrong value returned in update of CItem id: 208520
Wrong value returned in update of CItem id: 208520
Wrong value returned in update of CItem id: 208520
Wrong value returned in update of CItem id: 208520
Wrong value returned in update of CItem id: 208520
Wrong value returned in update of CItem id: 202288
Wrong value returned in update of CItem id: 207643
Wrong value returned in update of CItem id: 200149
Wrong value returned in update of CItem id: 200427
Wrong value returned in update of CItem id: 201134
Wrong value returned in update of CItem id: 206770
Wrong value returned in update of CItem id: 206771
Wrong value returned in update of CItem id: 207266
Wrong value returned in update of CItem id: 207266
Wrong value returned in update of CItem id: 207266
Wrong value returned in update of CItem id: 203038
Wrong value returned in update of CItem id: 20745

Add prediction for block 502000, branch 0x15C

morc
Posts: 72
Joined: Thu Jan 02, 2020 7:32 am

Re: Version 7.4.0.2897 progress

#654 Post by morc » Thu Jul 09, 2020 7:16 am

Could not find usable mount (have, ID 241622) dwarf

Add prediction for block 226000, branch 0x98
Add prediction for block 229000, branch 0xA4
Add prediction for block 212000, branch 0x29C

with human (m/r)

Use MACRO: MAGE_FANG_RITUAL =>Farsitan Ostrich 87%
Use MACRO: MAGE_ENERGY_INFLUX =>Farsitan Ostrich 84%
Use MACRO: MAGE_SHADOW_PROTECTION =>Farsitan Ostrich 81%
Engaging enemy [Farsitan Ostrich] in combat.
Use MACRO: MAGE_FLAME =>Farsitan Ostrich 81%
Use MACRO: MAGE_FANG_RITUAL =>Farsitan Ostrich 0%
Use MACRO: MAGE_SHADOW_PROTECTION =>Farsitan Ostrich 0%
Fight finished. Killed 1 Farsitan Ostrich. (fight #1 / runtime 0 minutes)

buff errors (m/r and k/m), but work :)

nuk79
Posts: 369
Joined: Mon May 17, 2010 3:40 pm

Re: Version 7.4.0.2897 progress

#655 Post by nuk79 » Mon Jul 13, 2020 7:56 am

Can someone help me with this .xml?player accept and delivery quest but when target npcs don't use properly items and i need to do manually?can you help me pls?
Attachments
drinknew.xml
(2.14 KiB) Downloaded 13 times

User avatar
Administrator
Site Admin
Posts: 5020
Joined: Sat Jan 05, 2008 4:21 pm

Re: Version 7.4.0.2897 progress

#656 Post by Administrator » Mon Jul 13, 2020 4:57 pm

morc wrote:
Thu Jul 09, 2020 7:16 am
Could not find usable mount (have, ID 241622) dwarf
What mount is that ID? Where is the mount stored (partner bag, inventory, item shop inventory)? I'm not able to reproduce this.
Use MACRO: MAGE_FANG_RITUAL =>Farsitan Ostrich 87%
Use MACRO: MAGE_ENERGY_INFLUX =>Farsitan Ostrich 84%
Use MACRO: MAGE_SHADOW_PROTECTION =>Farsitan Ostrich 81%
Engaging enemy [Farsitan Ostrich] in combat.
Use MACRO: MAGE_FLAME =>Farsitan Ostrich 81%
Use MACRO: MAGE_FANG_RITUAL =>Farsitan Ostrich 0%
Use MACRO: MAGE_SHADOW_PROTECTION =>Farsitan Ostrich 0%
Fight finished. Killed 1 Farsitan Ostrich. (fight #1 / runtime 0 minutes)

buff errors (m/r and k/m), but work :)
Sorry, I'm not sure I'm understanding. What is it that doesn't work here?

morc
Posts: 72
Joined: Thu Jan 02, 2020 7:32 am

Re: Version 7.4.0.2897 progress

#657 Post by morc » Wed Jul 15, 2020 2:14 am

Administrator wrote:
Mon Jul 13, 2020 4:57 pm
morc wrote:
Thu Jul 09, 2020 7:16 am
Could not find usable mount (have, ID 241622) dwarf
What mount is that ID? Where is the mount stored (partner bag, inventory, item shop inventory)? I'm not able to reproduce this.
Use MACRO: MAGE_FANG_RITUAL =>Farsitan Ostrich 87%
Use MACRO: MAGE_ENERGY_INFLUX =>Farsitan Ostrich 84%
Use MACRO: MAGE_SHADOW_PROTECTION =>Farsitan Ostrich 81%
Engaging enemy [Farsitan Ostrich] in combat.
Use MACRO: MAGE_FLAME =>Farsitan Ostrich 81%
Use MACRO: MAGE_FANG_RITUAL =>Farsitan Ostrich 0%
Use MACRO: MAGE_SHADOW_PROTECTION =>Farsitan Ostrich 0%
Fight finished. Killed 1 Farsitan Ostrich. (fight #1 / runtime 0 minutes)

buff errors (m/r and k/m), but work :)
Sorry, I'm not sure I'm understanding. What is it that doesn't work here?
Hi,

mount ID: 241622
in Item Shop inventory

buff errors:
The Fang Ritual, Shadow Protection, Energy Influx self buffs, but the bot use on enemy
and (if there is no target) keep trying to use it

User avatar
Administrator
Site Admin
Posts: 5020
Joined: Sat Jan 05, 2008 4:21 pm

Re: Version 7.4.0.2897 progress

#658 Post by Administrator » Sat Jul 18, 2020 11:41 am

morc wrote:
Wed Jul 15, 2020 2:14 am
Administrator wrote:
Mon Jul 13, 2020 4:57 pm
morc wrote:
Thu Jul 09, 2020 7:16 am
Could not find usable mount (have, ID 241622) dwarf
What mount is that ID? Where is the mount stored (partner bag, inventory, item shop inventory)? I'm not able to reproduce this.
Use MACRO: MAGE_FANG_RITUAL =>Farsitan Ostrich 87%
Use MACRO: MAGE_ENERGY_INFLUX =>Farsitan Ostrich 84%
Use MACRO: MAGE_SHADOW_PROTECTION =>Farsitan Ostrich 81%
Engaging enemy [Farsitan Ostrich] in combat.
Use MACRO: MAGE_FLAME =>Farsitan Ostrich 81%
Use MACRO: MAGE_FANG_RITUAL =>Farsitan Ostrich 0%
Use MACRO: MAGE_SHADOW_PROTECTION =>Farsitan Ostrich 0%
Fight finished. Killed 1 Farsitan Ostrich. (fight #1 / runtime 0 minutes)

buff errors (m/r and k/m), but work :)
Sorry, I'm not sure I'm understanding. What is it that doesn't work here?
Hi,

mount ID: 241622
in Item Shop inventory

buff errors:
The Fang Ritual, Shadow Protection, Energy Influx self buffs, but the bot use on enemy
and (if there is no target) keep trying to use it
I made a whole lot of changes around inventory management today. The mount should be working now. Please try and let me know if that resolves the issue.

morc
Posts: 72
Joined: Thu Jan 02, 2020 7:32 am

Re: Version 7.4.0.2897 progress

#659 Post by morc » Sun Jul 19, 2020 2:36 am

better but not good

bot find the mount
starts mounting, but do not wait, start off (the mounting break)
not waiting for the required time

User avatar
ThulsaDoom
Posts: 76
Joined: Mon Oct 19, 2015 2:46 pm

Re: Version 7.4.0.2897 progress

#660 Post by ThulsaDoom » Sun Jul 19, 2020 4:22 am

Thanks for your continuous job!

MM chrash when:

Code: Select all

inventory:update()
is executed

error:

Code: Select all

2020-07-19 11:11:49 - ...s/Documents/micromacro/scripts/rom/classes/inventory.lua:733: attempt to index global 'self' (a nil value)

Post Reply

Who is online

Users browsing this forum: No registered users and 8 guests