Version 7.4.0.2897 progress

Runes of Magic/Radiant Arcana (http://www.runesofmagic.com)
Message
Author
User avatar
Administrator
Site Admin
Posts: 5005
Joined: Sat Jan 05, 2008 4:21 pm

Re: Version 7.4.0.2897 progress

#621 Post by Administrator » Mon Jun 29, 2020 8:41 am

So the memorytable error only happens sometimes under certain circumstances, then?
I'm going to need you guys to start pointing out how/where I can trigger this. Unless I can reproduce it, it'll be next to impossible to fix.

morc
Posts: 69
Joined: Thu Jan 02, 2020 7:32 am

Re: Version 7.4.0.2897 progress

#622 Post by morc » Mon Jun 29, 2020 10:37 am

hmmm
character dependent not waypoint
to my mind is related to the number of open slots (backpack slots)

or unique item or number of items in backpack?

test:
same waypoint
1. character 1-2 backpack opened (60 slot) nothing problem
2. character 1-6 backpack opened (180 slot) .../classes/memorytable.lua:91: attempt to index field '?' (a string value)

next test (if I can do so much space):
totally empty backpack with 180 slots

surely something is wrong with the items
my character have mount (ID 241622) but according to MM he does not have

morc
Posts: 69
Joined: Thu Jan 02, 2020 7:32 am

Re: Version 7.4.0.2897 progress

#623 Post by morc » Tue Jun 30, 2020 2:21 am

tested with a completely empty backpack (normal and ItemShop backpack empty):

"Not much space left in inventory. Are you sure you want to continue with only 0 spaces left?"

waypoint attached
Attachments
far energetic.xml
(4.46 KiB) Downloaded 9 times

morc
Posts: 69
Joined: Thu Jan 02, 2020 7:32 am

Re: Version 7.4.0.2897 progress

#624 Post by morc » Tue Jun 30, 2020 3:55 am

Tested other waypoint (with empty backpack)

with M/R (continuous use the buffs):

Moving to waypoint #1, (1870, 1885) tag: start
Use MACRO: MAGE_FANG_RITUAL => <UNKNOWN> 0%
Use MACRO: MAGE_ENERGY_INFLUX => XXXXXXX 100%
Use MACRO: MAGE_FANG_RITUAL => XXXXXX 100%
Forced waypoint type 'TRAVEL' set by user.
We changed the option 'COMBAT_DISTANCE' from '0' to '0'.
Clearing target.
Moving to waypoint #2, (1933, 1905)
Use MACRO: MAGE_FANG_RITUAL => <UNKNOWN> 0%
Use MACRO: MAGE_FANG_RITUAL => XXXXXXXXX 100%
Use MACRO: MAGE_FANG_RITUAL => XXXXXXXXX 100%
Forced waypoint type 'TRAVEL' set by user.
Clearing target.
Moving to waypoint #3, (1990, 1931)
Use MACRO: MAGE_FANG_RITUAL => <UNKNOWN> 0%
The game client did not crash.
Character: XXXXXXX
2020-06-30 10:16:50 - .../classes/memorytable.lua:35: bad argument #1 to 'match' (string expected, got nil)

with K/M continuous use the buffs (Enchanced Armor) and instead of attacking just buff (without MM errors)

conclusion: error in backpack slots and item ID's
and buffs

User avatar
Administrator
Site Admin
Posts: 5005
Joined: Sat Jan 05, 2008 4:21 pm

Re: Version 7.4.0.2897 progress

#625 Post by Administrator » Wed Jul 01, 2020 9:37 am

Happy Canada Day!

I believe I've got the inventory issues sorted out now. Could you please update and confirm?

Meyerchen97
Posts: 1
Joined: Wed Jul 01, 2020 10:06 am

Re: Version 7.4.0.2897 progress

#626 Post by Meyerchen97 » Wed Jul 01, 2020 10:08 am

2020-07-01 17:05:14 - ...ktop/micromacro/scripts/rom-bot1/classes/memorytable.lua:91: attempt to index field '?' (a string value)

reports this error to me

nuk79
Posts: 366
Joined: Mon May 17, 2010 3:40 pm

Re: Version 7.4.0.2897 progress

#627 Post by nuk79 » Wed Jul 01, 2020 12:04 pm

Administrator wrote:
Wed Jul 01, 2020 9:37 am
Happy Canada Day!

I believe I've got the inventory issues sorted out now. Could you please update and confirm?
i don't have an aswert about inventory cause i have another problems .....this errors from andortraining.i don't know if it can help ty admin:)
C:/Program Files/micromacro/scripts/rom/functions.lua:2288: bad argument #1 to 'lower' (string expected, got nil)

User avatar
Administrator
Site Admin
Posts: 5005
Joined: Sat Jan 05, 2008 4:21 pm

Re: Version 7.4.0.2897 progress

#628 Post by Administrator » Wed Jul 01, 2020 12:16 pm

nuk79 wrote:
Wed Jul 01, 2020 12:04 pm
Administrator wrote:
Wed Jul 01, 2020 9:37 am
Happy Canada Day!

I believe I've got the inventory issues sorted out now. Could you please update and confirm?
i don't have an aswert about inventory cause i have another problems .....this errors from andortraining.i don't know if it can help ty admin:)
C:/Program Files/micromacro/scripts/rom/functions.lua:2288: bad argument #1 to 'lower' (string expected, got nil)
Hmm, that function is receiving nil, but from where I don't know. Could you open up your log.txt and copy/paste the stacktrace (be sure to remove any personal details about you or your character(s) first though)? That should be the last few lines in the file.

morc
Posts: 69
Joined: Thu Jan 02, 2020 7:32 am

Re: Version 7.4.0.2897 progress

#629 Post by morc » Thu Jul 02, 2020 4:01 am

Administrator wrote:
Wed Jul 01, 2020 9:37 am
Happy Canada Day!

I believe I've got the inventory issues sorted out now. Could you please update and confirm?
Hi,

backpack slot problem solved
mount problem not solved (Could not find usable mount)

I will continue to test...

morc
Posts: 69
Joined: Thu Jan 02, 2020 7:32 am

Re: Version 7.4.0.2897 progress

#630 Post by morc » Thu Jul 02, 2020 7:39 am

morc wrote:
Thu Jul 02, 2020 4:01 am
Administrator wrote:
Wed Jul 01, 2020 9:37 am
Happy Canada Day!

I believe I've got the inventory issues sorted out now. Could you please update and confirm?
Hi,

backpack slot problem solved
mount problem not solved (Could not find usable mount)

I will continue to test...
2020-07-02 14:38:33 - .../rom/classes/memorytable.lua:91: attempt to index field '?' (a string value) :(

User avatar
Administrator
Site Admin
Posts: 5005
Joined: Sat Jan 05, 2008 4:21 pm

Re: Version 7.4.0.2897 progress

#631 Post by Administrator » Thu Jul 02, 2020 8:11 am

morc wrote:
Thu Jul 02, 2020 7:39 am
morc wrote:
Thu Jul 02, 2020 4:01 am
Administrator wrote:
Wed Jul 01, 2020 9:37 am
Happy Canada Day!

I believe I've got the inventory issues sorted out now. Could you please update and confirm?
Hi,

backpack slot problem solved
mount problem not solved (Could not find usable mount)

I will continue to test...
2020-07-02 14:38:33 - .../rom/classes/memorytable.lua:91: attempt to index field '?' (a string value) :(
Is that still only when on a character that has all bags unlocked, or something else?

lolau51
Posts: 24
Joined: Wed Oct 05, 2011 4:40 am

Re: Version 7.4.0.2897 progress

#632 Post by lolau51 » Thu Jul 02, 2020 8:33 am

morc wrote:
Mon Jun 29, 2020 5:20 am
with me too...
but not on all waypoints

and other problems:

the "new" d303 fix not working: failed reading from itemshop and after each teleport opens the ItemShop window

newest update detects 0 free backpack slot if all tab unlocked
My D303 config :
Image
I never have the cashchop poping.

morc
Posts: 69
Joined: Thu Jan 02, 2020 7:32 am

Re: Version 7.4.0.2897 progress

#633 Post by morc » Thu Jul 02, 2020 8:41 am

Administrator wrote:
Thu Jul 02, 2020 8:11 am
morc wrote:
Thu Jul 02, 2020 7:39 am
morc wrote:
Thu Jul 02, 2020 4:01 am


Hi,

backpack slot problem solved
mount problem not solved (Could not find usable mount)

I will continue to test...
2020-07-02 14:38:33 - .../rom/classes/memorytable.lua:91: attempt to index field '?' (a string value) :(
Is that still only when on a character that has all bags unlocked, or something else?
yes, just that

morc
Posts: 69
Joined: Thu Jan 02, 2020 7:32 am

Re: Version 7.4.0.2897 progress

#634 Post by morc » Thu Jul 02, 2020 8:44 am

lolau51 wrote:
Thu Jul 02, 2020 8:33 am
morc wrote:
Mon Jun 29, 2020 5:20 am
with me too...
but not on all waypoints

and other problems:

the "new" d303 fix not working: failed reading from itemshop and after each teleport opens the ItemShop window

newest update detects 0 free backpack slot if all tab unlocked
My D303 config :
Image
I never have the cashchop poping.
yes, but you you turned off the Item Shop probing

User avatar
Administrator
Site Admin
Posts: 5005
Joined: Sat Jan 05, 2008 4:21 pm

Re: Version 7.4.0.2897 progress

#635 Post by Administrator » Thu Jul 02, 2020 3:00 pm

Item shop probing doesn't seem to work anymore and I'm not entirely sure if it is something that is fixable or not.

Anyways, I'll look at the outstanding inventory issues as time allows. I was just informed that another department in the company I work for had a bit of a data breach issue. Naturally, it now falls on me to figure out the solution for them. Needless to say, I'm going to busy over the next few days.

nuk79
Posts: 366
Joined: Mon May 17, 2010 3:40 pm

Re: Version 7.4.0.2897 progress

#636 Post by nuk79 » Sat Jul 04, 2020 4:59 am

morc wrote:
Thu Jul 02, 2020 8:44 am
lolau51 wrote:
Thu Jul 02, 2020 8:33 am
morc wrote:
Mon Jun 29, 2020 5:20 am
with me too...
but not on all waypoints

and other problems:

the "new" d303 fix not working: failed reading from itemshop and after each teleport opens the ItemShop window

newest update detects 0 free backpack slot if all tab unlocked
My D303 config :
Image
I never have the cashchop poping.
yes, but you you turned off the Item Shop probing
try to cancel second phrase in dod.xml.maybe works

User avatar
Administrator
Site Admin
Posts: 5005
Joined: Sat Jan 05, 2008 4:21 pm

Re: Version 7.4.0.2897 progress

#637 Post by Administrator » Sat Jul 04, 2020 12:26 pm

I'm still having trouble reproducing the issue. I unlocked all bags and just let the bot run. Even after all 6 bags filled up, the bot continued to run without issue.

Of course, I did not actually pay to unlock the bags, but instead just pulled some bullshit magic to let me place items into those bags anyways. I can't imagine that would actually affect anything at all though.
Annotation 2020-07-04 113627.png
Is there any more information you guys can provide? Does it error out right away, or take awhile? Only when running certain waypoints?

morc
Posts: 69
Joined: Thu Jan 02, 2020 7:32 am

Re: Version 7.4.0.2897 progress

#638 Post by morc » Sun Jul 05, 2020 12:59 am

Administrator wrote:
Sat Jul 04, 2020 12:26 pm
I'm still having trouble reproducing the issue. I unlocked all bags and just let the bot run. Even after all 6 bags filled up, the bot continued to run without issue.

Of course, I did not actually pay to unlock the bags, but instead just pulled some bullshit magic to let me place items into those bags anyways. I can't imagine that would actually affect anything at all though.
Annotation 2020-07-04 113627.png

Is there any more information you guys can provide? Does it error out right away, or take awhile? Only when running certain waypoints?
always on this route
but only with the character to whom all are open backpack
Attachments
tos_easy_tpfarm_v2.xml
(3.68 KiB) Downloaded 10 times

User avatar
Administrator
Site Admin
Posts: 5005
Joined: Sat Jan 05, 2008 4:21 pm

Re: Version 7.4.0.2897 progress

#639 Post by Administrator » Sun Jul 05, 2020 7:27 am

I'm still not able to trigger it. I tried extracting the code out of that waypoint file and calling it directly, using the same hack as before to unlock all of my bags. I think it has something to do with the exact area your character is in or inventory contents.

Does it only happen at a specific waypoint or doing a specific action (say, using a potion)?

nuk79
Posts: 366
Joined: Mon May 17, 2010 3:40 pm

Re: Version 7.4.0.2897 progress

#640 Post by nuk79 » Sun Jul 05, 2020 8:58 am

I noticed that sometimes the bot gets stuck on some dailies .... with some players it works with others not, but the same daily.....not works for knight classes and priest classes ... how is it possible?

The 'Attack' hotkey is set to 'macro'.
Testing 'ingamefunctions' macro. If it gets stuck here, please update the 'ingamefunctions' by copying the 'ingamefunctions' folder from 'rom/devtools' to the game's 'interface/addons' folder.
MACRO Test: ok
[!] d303Fix is not installed; some waypoints might not work correctly.
You can fix this by copying the '#d303fix' folder from 'rom/devtools' to the game's 'interface/addons' folder.The macro hotkey is F9.
The 'Attack' hotkey is set to 'macro'.
Ranged skill found: PRIEST_RISING_TIDE
[DEBUG] CPU Frequency 10000
Add prediction for block 215000, branch 0x2A4
Add prediction for block 235000, branch 0xBC
Loaded waypoint path drinknew.xml
No return path with default naming drinknew_return.xml found.
We use the normal waypoint path drinknew.xml now.
Clearing target.
Moving to waypoint #1, (-11776, -5642) tag: start
The game client did not crash.

ram Files/micromacro/scripts/rom/classes/memorytable.lua:91: attempt to index field '?' (a string value)

i delete and copy lat update of rom master
Last edited by nuk79 on Sun Jul 05, 2020 9:11 am, edited 4 times in total.

Post Reply

Who is online

Users browsing this forum: No registered users and 11 guests