MM2 1.92.46 readptr

Discuss, ask for help, share ideas, give suggestions, read tutorials, and tell us about bugs you have found with MicroMacro in here.

Do not post RoM-Bot stuff here. There is a subforum for that.
Forum rules
This is a sub-forum for things specific to MicroMacro.

This is not the place to ask questions about the RoM bot, which uses MicroMacro. There is a difference.
Post Reply
Message
Author
User avatar
lisa
Posts: 8330
Joined: Tue Nov 09, 2010 11:46 pm
Location: Australia

MM2 1.92.46 readptr

#1 Post by lisa » Mon Dec 07, 2015 4:14 am

Ok I don't know if I did something wrong but it really seems like when you have more than 1 offset in the readPtr it stops working.

Code: Select all

local stam = process.readPtr(proc, "int", (0x1AAB0000 + 0x5C1B8), {0x68}) -- 0x68, 0x210,0x5C8, 0x0, 0x464
		if stam then printf("0x%X\n",stam) else printf("stam not working\n") end
That print works fine as it is.
stam1.png

Code: Select all

local stam = process.readPtr(proc, "int", (0x1AAB0000 + 0x5C1B8), {0x68 ,0x210}) -- 0x68, 0x210,0x5C8, 0x0, 0x464
		if stam then printf("0x%X\n",stam) else printf("stam not working\n") end
That fails.
stam2.png
stam2.png (28.12 KiB) Viewed 1834 times
In the first pick you can see cheat engine on the side and the values it should be, the first offset works fine but when I add in another offset it fails, even just adding 0x0 it still fails

I tried
{0x68,0x210}
{0x68 , 0x210}
{0x68 ,0x210}
{0x68, 0x210}
Just in case for some reason the space was messing with it lol

Doing this works fine.

Code: Select all

local stam = process.readPtr(proc, "int", (0x1AAB0000 + 0x5C1B8), {0x68}) -- 0x68, 0x210,0x5C8, 0x0, 0x464
		stam = process.read(proc, "int", stam+0x210)
		stam = process.read(proc, "int", stam+0x5C8)
		stam = process.read(proc, "int", stam+0x0)
		stam = process.read(proc, "float", stam+0x464)
		if stam then printf("%d\n",stam) else printf("stam not working\n") end
Remember no matter you do in life to always have a little fun while you are at it ;)

wiki here http://www.solarstrike.net/wiki/index.php?title=Manual

User avatar
BlubBlab
Posts: 948
Joined: Fri Nov 30, 2012 11:33 pm
Location: My little Pony cafe

Re: MM2 1.92.46 readptr

#2 Post by BlubBlab » Mon Dec 07, 2015 6:36 am

This is admins version ?

Admin may check out the lua_next besides that I can't see any thing that can go wrong and I need sleep^^
Jack-of-all-trades, but master-of-only of a few :D

My Reps:
https://github.com/BlubBlab/Micromacro-with-OpenCV (My version of MM2 with OpenCV and for MS Visual Studio)
https://github.com/BlubBlab/rom-bot (rombot with no stop WP and advanced human emulation mode and some other extensions)
https://github.com/BlubBlab/Micromacro-2-Bot-Framework ( A work in progress )
My Tools : viewtopic.php?f=10&t=6226

User avatar
Administrator
Site Admin
Posts: 4857
Joined: Sat Jan 05, 2008 4:21 pm

Re: MM2 1.92.46 readptr

#3 Post by Administrator » Mon Dec 07, 2015 2:49 pm

Trying to investigate this and stumbled upon an issue. Windows 10 has decided to corrupt the owner of micromacro.exe, preventing me from re-compiling it. Or deleting it. Or... anything. I can't even reset the owner to myself (even though it is inherited from a folder that I own). This is making it pretty difficult to actually do any testing.


Anyone seen this before? Have a fix for it that doesn't require me to reboot into Linux in order to fix the NTFS drive?

User avatar
lisa
Posts: 8330
Joined: Tue Nov 09, 2010 11:46 pm
Location: Australia

Re: MM2 1.92.46 readptr

#4 Post by lisa » Mon Dec 07, 2015 3:38 pm

Sorry Admin, I don't have windows 10 so I couldn't say.
Remember no matter you do in life to always have a little fun while you are at it ;)

wiki here http://www.solarstrike.net/wiki/index.php?title=Manual

User avatar
Administrator
Site Admin
Posts: 4857
Joined: Sat Jan 05, 2008 4:21 pm

Re: MM2 1.92.46 readptr

#5 Post by Administrator » Mon Dec 07, 2015 4:20 pm

Here's a fix that (should) work. I've only included the binaries; both 32 and 64 bit.
Attachments
mm.ptrfix.binaries.zip
(559.54 KiB) Downloaded 55 times

User avatar
BlubBlab
Posts: 948
Joined: Fri Nov 30, 2012 11:33 pm
Location: My little Pony cafe

Re: MM2 1.92.46 readptr

#6 Post by BlubBlab » Mon Dec 07, 2015 5:05 pm

Can you say what went wrong ?
Jack-of-all-trades, but master-of-only of a few :D

My Reps:
https://github.com/BlubBlab/Micromacro-with-OpenCV (My version of MM2 with OpenCV and for MS Visual Studio)
https://github.com/BlubBlab/rom-bot (rombot with no stop WP and advanced human emulation mode and some other extensions)
https://github.com/BlubBlab/Micromacro-2-Bot-Framework ( A work in progress )
My Tools : viewtopic.php?f=10&t=6226

User avatar
Administrator
Site Admin
Posts: 4857
Joined: Sat Jan 05, 2008 4:21 pm

Re: MM2 1.92.46 readptr

#7 Post by Administrator » Mon Dec 07, 2015 5:25 pm

Logic error. It was due to the order of adding offset in. It was reading the address with each offset in sequence, should have been reading the address and then adding the offset to the result.

https://github.com/elverion/micromacro/ ... d831dfe91f

User avatar
lisa
Posts: 8330
Joined: Tue Nov 09, 2010 11:46 pm
Location: Australia

Re: MM2 1.92.46 readptr

#8 Post by lisa » Tue Dec 08, 2015 8:30 am

Thanks I'll give it a test, unfortunately the pointers I had didn't hold up but yeah I'll give it a test anyway on another pointer.

--=== Added ===--
Tested micromacro.exe and it works fine =)
Remember no matter you do in life to always have a little fun while you are at it ;)

wiki here http://www.solarstrike.net/wiki/index.php?title=Manual

Post Reply

Who is online

Users browsing this forum: No registered users and 1 guest